Meta-Analysis Resources

Tools for Those Who Summarize the Evidence Base

Resources and networking for those who conduct or interpret meta-analyses related to any phenomenon that is gauged in multiple studies.

Hello Everybody:

 

I am new in this forum. Great that it exists. Unfortunately, the first thing I need to ask for is your advice.

 

Despite the recent swing towards open source software, I still use LISREL and would like to run a MASEM CFA model using this software (version 9.1). Mike kindly provided me with the current link to his old LISREL materials. Before specifying my own model, I tried to reproduce the model from the sample data provided to find whether everything works properly. Yet I faced a problem.

 

The TSSEM-LISREL manual includes an excerpt from the output file 'cor1.out' quoting the pooled correlation matrix (PHI) and the fit indices. Yet when I opened the respective file provided in the materials, this file did not contain any pooled PHI Matrix (it does contain the single group matrices, though), and the overall fit indices are different from those printed in the manual. When I try to run the ls8-file (converted to .spl in Lisrel 9), I am able to reproduce the output-file in the materials but NOT the results printed in the Manual. Now I am lost.

 

Cheers,

 

Bernd

Views: 135

Replies to This Discussion

Hi Bernd,

I tried to run my old LISREL sample code in LISREL 9.2 (student version) a few months ago. There were errors and the results were quite different from LISREL 8. I couldn't tell what has been changed in LISREL.

I am afraid that it is not maintained any more. I would strongly suggest to use the metaSEM package implemented in R. The LISREL approach is limited to fixed-effects MASEM while the metaSEM package includes both fixed- and random-effects MASEM.

Regards,
Mike

Thanks for getting back to me, Mike. I understand that you recommend using R now. Yet in case I don't find the time to make myself familiar with R syntax in the near future (as I am afraid I won't), do you think your LISREL macros will run in LISREL 8.8? I still have access to that version but remember that you somewhere wrote to have faced bugs in 8.8, too.

Cheers, Bernd

Hi Bernd,

I don't think that it works in LISREL 8.8. It was a confirmed bug in LISREL 8.8. They sent me a patched binary file many years ago. I don't have it any more. The latest version that works with me is LISREL 8.7.

Cheers,
Mike

OK. Thanks, Bernd

RSS

© 2017   Created by Blair T. Johnson.   Powered by

Badges  |  Report an Issue  |  Terms of Service