Meta-Analysis Resources

Tools for Those Who Summarize the Evidence Base

Resources and networking for those who conduct or interpret meta-analyses related to any phenomenon that is gauged in multiple studies.

Dear Mike and MASEM users, 

I am testing the same mediation model with several different datasets. Each dataset contains data on a different candidate mediator and has different number of study matrices with different patterns of missing data.

For some of the datasets, tssem1 and tssem2 seem to run perfectly well, openmx status=0, no error or warning messages, and there are ubound and lbound for me to interpret the indirect effect and direct effect. For other datasets, openmx status=0, but I see "NA" in either the ubound, the lbound, or both for the indirect and direct effects. Here is the output from one such dataset:

Call:
wls(Cov = pooledS, asyCov = asyCov, n = tssem1.obj$total.n, Amatrix = Amatrix,
Smatrix = Smatrix, Fmatrix = Fmatrix, diag.constraints = diag.constraints,
cor.analysis = cor.analysis, intervals.type = intervals.type,
mx.algebras = mx.algebras, model.name = model.name, suppressWarnings = suppressWarnings,
silent = silent, run = run)

95% confidence intervals: Likelihood-based statistic
Coefficients:
Estimate Std.Error lbound ubound z value Pr(>|z|)
m1m3 0.4531497 NA 0.2754217 0.6309407 NA NA
Txm3 0.0090453 NA -0.0724801 0.0905704 NA NA
m3o3 -0.0763300 NA -0.2543311 0.1020654 NA NA
o1o3 0.4696471 NA 0.4028079 0.5361803 NA NA
Txo3 -0.0025988 NA -0.0748088 0.0696686 NA NA
var_m3 0.7945735 NA 0.6018275 0.9240713 NA NA
r_m1o1 -0.0607255 NA -0.2454219 0.1197996 NA NA
var_o3 0.7716221 NA 0.6914914 0.8323063 NA NA

mxAlgebras objects (and their 95% likelihood-based CIs):
lbound Estimate ubound
medD[1,1] NA -0.0006904273 NA
dirD[1,1] NA -0.0019083397 NA

Goodness-of-fit indices:
Value
Sample size 544.0000
Chi-square of target model 1.0107
DF of target model 4.0000
p value of target model 0.9082
Number of constraints imposed on "Smatrix" 2.0000
DF manually adjusted 0.0000
Chi-square of independence model 223.5196
DF of independence model 10.0000
RMSEA 0.0000
RMSEA lower 95% CI 0.0000
RMSEA upper 95% CI 0.0258
SRMR 0.0254
TLI 1.0350
CFI 1.0000
AIC -6.9893
BIC -24.1851
OpenMx status1: 0 ("0" or "1": The optimization is considered fine.
Other values indicate problems.)

I already put in the modifications that Mike suggested in previous correspondence when I was getting openmx status=6 for tssem1, which did make the openmx status=0.

These modifications are: 1. changing the variance of the missing variables in each study matrix from 1 to NA, and 2. manually fixing to 0 the heterogeneity indices (I2) that are close to 0,'

 

I would appreciate any help with understanding why this problem is occurring and how to fix it.

Thank you!

Mei Yi

Views: 21

Replies to This Discussion

Sorry so slow in posting!

Hi Mei Yi,

I think that I have replied some of your issues at http://openmx.ssri.psu.edu/node/4244

If not, please post another one.

Best,

Mike

RSS

© 2017   Created by Blair T. Johnson.   Powered by

Badges  |  Report an Issue  |  Terms of Service